1с статьи | Курс-репетитор программиста 1С
Структура

Создание и наполнение

// создали структуру без ключей
Структура = Новый Структура();

// добавили ключ - значение
Структура.Вставить("Фамилия", "Еникеев");
Структура.Вставить("Имя", "Марат");
Структура.Вставить("Отчество", "Артурович");

// создали структуру с ключами, значения - Неопределно
КлючиСтруктуры = "Фамилия, Имя, Отчество";
Структура = Новый Структура(КлючиСтруктуры);

// создали структуру с ключами и значениями
КлючиСтруктуры = "Фамилия, Имя, Отчество";
Структура = Новый Структура(КлючиСтруктуры, 
   "Еникеев", "Марат", "Артурович");

Фамилия = Структура.Фамилия;

Имя = Структура["Имя"];

Отчество = Неопределено;
Если Структура.Свойство("Отчество", Отчество) Тогда
   // есть ключ Отчество, 
   // значение считано в переменную Отчество
КонецЕсли;

Если Структура.Количество() Тогда
   // структура содержит ключи
КонецЕсли;

Массив = Новый Массив;
Структура.Вставить("1", Массив);

// Почему возникла ошибка
// "Задано неправильное имя атрибута структуры"?

Показать решение

Обход и изменение

// создали структуру с ключами и значениями
КлючиСтруктуры = "Фамилия, Имя, Отчество";
Структура = Новый Структура(КлючиСтруктуры, 
   "Еникеев", "Марат", "Артурович");

// удаление свойств происходит по ключу
Структура.Удалить("Имя");

Структура.Вставить("_НовоеСвойство");

// обход осуществляется в порядке
// добавления элементов в структуру
// сортировка по ключу не осуществляется
Для Каждого Элемент Из Структура Цикл
   // Элемент имеет тип КлючИЗначение 
   ТекстСообщения = СтрШаблон("ключ %1, значение %2", 
      Элемент.Ключ, Элемент.Значение);
   Сообщить(ТекстСообщения);
КонецЦикла; 

// Что будет выведено?

Показать решение

Слишком маленькое разрешение экрана.